Problems wih edit.tosdr.org – no markup/linebreaks, annotations get lost

Hi, long time user and fan, first time (at least using the new editor) contributor.

I started taking a crack at the Firefox Accounts service and am running into issues with edit.tosdr.org that I hope someone can help me with:

  • when the site gets crawled, the (basic) HTML tags seem to get pulled in, but then in the annotation mode completely ignored, which makes reading the text you are supposed to annotate extremely difficult. Especially with missing line breaks, paragraphs etc.
  • it happened more than once that after I saved an annotation, it did not show up anymore in the document view.

Keep up the good work, and I hope to finally drop by and help out from time to time :slight_smile:

2 Likes

Same problem with annotations. :face_with_raised_eyebrow:

Currently reviewing a couple Services and annotations don’t get added after a certain point.

1 Like

Could you send a link for the document you are having the issue with?

1 Like

I have checked the document you have sent me via PM and have not noticed any disappearing points, however @hook discovered a rather weird bug as I have annotated a point on the WeMode Service and it seems that when I have created the point the markup bugged out and now the html is cut off in the annotation view, see screenshot below.

1 Like

@Peepo @JustinBack
Strangely enough, I’m starting to notice html tags appearing on user points for review. :thinking: :thinking: :thinking:

image

2 Likes

I was working on this document when I found it: https://edit.tosdr.org/services/188/annotate#doc_2819

1 Like

Thats interesting, maybe we should open an issue on GitHub for this

2 Likes